10-排序6 Sort with Swap(0, i) (25分)

Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, ) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:
给定数字{0,1,2,…,N-1}的任何排列,很容易按升序对它们进行排序。 但是,如果Swap(0,
)是允许使用的唯一操作怎么办? 例如,要对{4,0,2,1,3}进行排序,我们可以通过以下方式应用交换操作:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}
交换(0,1)=> {4,1,2,0,3}
交换(0,3)=> {4,1,2,3,0}
交换(0,4)=> {0,1,2,3,4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.
现在,要求您查找对前N个非负整数的给定排列进行排序所需的最小交换次数。

Input Specification:

Each input file contains one test case, which gives a positive N (≤10​5​​ ) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.
每个输入文件包含一个测试用例,给出正N(≤105)后跟{0,1,…,N-1}的排列顺序。 一行中的所有数字都用空格分隔。

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.
对于每种情况,只需在一行中打印对给定排列进行排序所需的最少交换次数即可。

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

解析

  1. 数组存储的是序号,例如第一次输入是3,则a[3] = 0。
  2. 假如a[0] =7 和 a[7] = 2,则交换为a[7]=7 和 a[0]=2
  3. 每一次都是用a[0]来交换,如果a[0]=0,则把a[0]与其他不合格的数字交换再循环执行

代码

#include<bits/stdc++.h>
using namespace std;
int a[100020];
int n;
int main(){
    cin>>n;
    int left=n-1,x;
    for(int i=0;i<n;i++){    //输入的是数组的序数而不是值
        cin>>x;
        a[x]=i;
        if(x==i&&x!=0){        //如果序数与值相同则循环次数减一
            left--;
        }
    }
    int cnt=0,k=1;
    while(left>0){
        if(a[0]==0){
            while(k<n){
                if(a[k]!=k){
                    swap(a[0],a[k]);
                    cnt++;
                    break;
                }
                k++;
            }
        }
        if(a[0]!=0){
            swap(a[0],a[a[0]]);
            cnt++;
            left--;
        }    
    }
    cout<<cnt;
    return 0;
}