已知树的前序和中序遍历后序

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

代码

num数组内保存是前序,num1是中序,函数create创建树,print后序遍历树。

#include <bits/stdc++.h>
using namespace std;
const int maxn = 35;
struct Node{
    int data;
    Node* left;
    Node* right;
};
int num[35],n,num1[35],flag=0;
Node* create(int pl,int pr,int il,int ir){
    if(pl>pr)
        return NULL;
    Node* root = new Node;
    root->data=num[pl];
    int k;
    for(k=il;k<=ir;k++){
        if(num1[k]==num[pl]){
            break;
        }
    }
    int numleft = k -il;
    root->left=create(pl+1,numleft+pl,il,k-1);
    root->right=create(pl+numleft+1,pr,k+1,ir);
    return root;
    
}

void print(Node* root){
    if(root==NULL)
        return ;
    print(root->left);
    print(root->right);
    if(flag==1){
        cout<<" "<<root->data;
    }
    if(flag==0){
        cout<<root->data;
        flag=1;
    }    
        
}
int main(){
    int x,k1=0,k2=0;
    char a[10],b[10]="Push";
    cin>>n;
    stack<int> st;
     
    for(int i=1;i<=2*n;i++){
        cin>>a;
        if(strcmp(a,b)==0){
            cin>>x;
            st.push(x);
            num[k1++]=x;
        }else{
            num1[k2]=st.top();
            k2++;
            st.pop();
        }
    }
    Node* root = create(0,n-1,0,n-1);
    print(root);
    
    return 0;
}